From c855e0080ea1fd52beb51a3e7589190aa192163d Mon Sep 17 00:00:00 2001
From: Morre <morre@cccv.de>
Date: Tue, 7 Jun 2022 20:11:30 +0200
Subject: [PATCH] feat: bump to 23.0.5

---
 README.md           | 3 +++
 scripts/appstore.py | 4 ++--
 2 files changed, 5 insertions(+), 2 deletions(-)
 create mode 100644 README.md

diff --git a/README.md b/README.md
new file mode 100644
index 0000000..851cdd1
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# nextcloud-apps
+
+This repo packages Nextcloud apps to .deb packages. The apps that are packaged are configured in [config/apps](config/apps).
diff --git a/scripts/appstore.py b/scripts/appstore.py
index d136f87..0c85a7b 100755
--- a/scripts/appstore.py
+++ b/scripts/appstore.py
@@ -119,7 +119,7 @@ def create_debian_dir(app):
 		for dep in get_debian_packages_for_php_extension(php_ext['id'], minver, maxver):
 			if dep not in dependencies:
 				dependencies.append(dep)
-	
+
 	with open('debian/control', 'w') as f:
 		f.write(f'''\
 Source: nextcloud-app-{ app['id'].replace('_', '-') }
@@ -191,7 +191,7 @@ def update():
 	#latest_stable_version = platforms[-1]['version']
 	#if latest_stable_version.endswith('.0.0'):
 	#	latest_stable_version = platforms[-2]['version']
-	latest_stable_version = '22.2.4'
+	latest_stable_version = '23.0.5'
 	r = requests.get(f'https://apps.nextcloud.com/api/v1/platform/{latest_stable_version}/apps.json')
 	apps = r.json()
 	apps.sort(key=lambda app: app['id'])
-- 
GitLab